Ga terug   Computer Idee Forum > Software > Software Overige

Antwoord
 
Discussietools Weergave
Oud 15 April 2006, 15:53   #1
anoniem18532
Guest
 
Berichten: n/a
Standaard Ophogen tijdstip met 1 uur in excel

Hallo

Ik krijg dagelijks een bestand aangeleverd in Excel.
In dit bestand bevindt zich een kolom waarin tijdstippen staan vermeld en een kolom met daarin de datums, die bij deze tijdstippen horen
Voorbeeld:
22:01:36 14-04-06

Nu moet ik in verband met de komst van de zomertijd in de kolom waar de tijd staat vermeld standaard een uur bij de aangeleverde tijd optellen.
Indien het tijdstip zich echter bevindt tussen 23.00 uur en 23.59 uur moet uiteraard ook de datum met een dag opgehoogd worden.
22:01:36 14-04-06 moet worden: 23:01:36 14-04-06 maar
23:01:36 14-04-06 moet worden: 00:01:36 15-04-06.

Uiteraard zou ik er enorm bij gebaad zijn als ik deze handeling zou kunnen automatiseren.

Weet iemand de formule in Excel, die ik hiervoor zou kunnen gebruiken?

BvD
  Met citaat antwoorden
Oud 22 April 2006, 16:39   #2
anoniem13803
Guest
 
Berichten: n/a
Standaard

Als in A1 de tijd staat en in B1 de datum dan het volgende.
Zet voor de tijd in een nieuwe cel een formule die de tijd met 24 x zo groot maakt, doe daar 1 bij en deel dit weer door 24.
In Excel zo =(A1*24+1)/24
Zet voor de datum ook in een nieuwe cel een formule die deze datum alleen ophoogt als de tijd boven de 24 uur komt.
In Excel =ALS((A1*24+1)>24;B1+1;B1)

  Met citaat antwoorden
Oud 25 April 2006, 17:41   #3
anoniem18563
Guest
 
Berichten: n/a
Standaard

hallo
ik heb een makkelijkere oplossing als hanand gevonden
in a1 zet je de datum
in b1 zet je de tijd
in c1 zet je dan de tijd die je er bij wilt optellen in dit geval dus 1 uur
in d1 zet je dan het volgende =A1+B1+C1
het kan zijn dat je het tabel tiepe van d1 moet wijzigen naar eentje waar datum en tijd in staad als dat niet automaties gebeurd
dat is ook zo bij c1 maar daar moet je er gewoon een tijd tabel van maken
groetjes robert
  Met citaat antwoorden
Oud 27 April 2006, 02:54   #4
anoniem15014
Guest
 
Berichten: n/a
Standaard

Als in cel A1 de tijd staat, dan wordt de formule:
=A1+TIJD(1;0;0)
De bijbehorende datum wordt eventueel automatisch aangepast.
  Met citaat antwoorden
Antwoord

Discussietools
Weergave

Regels voor berichten
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is Aan
Smileys zijn Aan
[IMG]-code is Aan
HTML-code is Uit

Forumnavigatie


Alle tijden zijn GMT +1. Het is nu 09:25.


Powered by vBulletin Version 3.8.6
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.