Belangrijk: ComputerIdee Forum Huisregels | Wachtwoord vergeten?

Ga terug   Computer Idee Forum > Software > Software Overige

Notices

Antwoord
 
Discussietools Weergave
Oud 20 December 2016, 08:28   #1
sr-1340
 
Geregistreerd: 20 December 2016
Berichten: 3
Standaard Excel formule: #N/B omzetten

Weet iemand hoe je de volgende formule zodanig kan ombouwen dat er geen #N/B verschijnt maar bijvoorbeeld "0" of "-"
Ik heb al veel opgezocht als het gaat om het gebruik van ISNB of ALS.FOUT, maar omdat er een dubbele zoekwaarde instaat lukt het niet om dit geldig in te bouwen.


De formule is op deze manier opgebouwd:


=ALS(B3="jan";VERT.ZOEKEN(A3;F:I;2;ONWAAR);ALS(B3= "feb";VERT.ZOEKEN(A3;F:I;3;ONWAAR);ALS(B3="mrt";VE RT.ZOEKEN(A3;F:I;4;ONWAAR))))

In de bijlage zou er dus bij de naam "de Jong" geen #N/B moeten verschijnen, maar bijvoorbeeld "0" zodat de totaaltelling weer werkt.
Dank voor jullie meedenken vast!
Bijgevoegde bestanden
Bestandstype: zip Formule #NB.zip‎ (21,9 KB, 7x gelezen)

Laatst gewijzigd door sr-1340 : 20 December 2016 om 09:00
sr-1340 is offline   Met citaat antwoorden
Oud 20 December 2016, 08:43   #2
adbecude
 
Geregistreerd: 11 December 2006
Locatie: Slijkplaat (Ergens in de polder van zeeuws-vlaanderen)
Berichten: 378
Standaard

sr-1340,
Je bijgevoegde bestandje kan ik niet openen, waarom geen .xls of .xlsx voorbeeldje? Dan kunnen we je beter helpen.
__________________
Laat niet als dank...........maar laat ff weten of je probleem opgelost is....of niet.
Groet Ad.
adbecude is offline   Met citaat antwoorden
Oud 20 December 2016, 08:55   #3
sr-1340
 
Geregistreerd: 20 December 2016
Berichten: 3
Standaard

Citaat:
Oorspronkelijk geplaatst door adbecude Bekijk bericht
sr-1340,
Je bijgevoegde bestandje kan ik niet openen, waarom geen .xls of .xlsx voorbeeldje? Dan kunnen we je beter helpen.
Beste Ad,
dank voor je snelle reactie, echter, ik krijg geen .xls extensies ge-upload. Dat wordt niet geaccepteerd.
ik zal nog 's kijken...groet, Stefan

(is inmiddels gelukt als het goed is via een zip file)

Laatst gewijzigd door sr-1340 : 20 December 2016 om 09:00
sr-1340 is offline   Met citaat antwoorden
Oud 20 December 2016, 13:01   #4
Edmoor
 
Edmoor's schermafbeelding
 
Geregistreerd: 17 March 2005
Berichten: 3.857
Standaard

Maak er dit van:
Code:
=ALS.FOUT(ALS(B12="jan";VERT.ZOEKEN(A12;F:J;2;ONWAAR);ALS(B12="feb";VERT.ZOEKEN(A12;F:J;3;ONWAAR);ALS(B12="mrt";VERT.ZOEKEN(A12;F:J;4;ONWAAR);ALS(B12="apr";VERT.ZOEKEN(A12;F:J;5;ONWAAR)))));0)
__________________
<---The information went data way ---
Edmoor is offline   Met citaat antwoorden
Oud 20 December 2016, 13:56   #5
sr-1340
 
Geregistreerd: 20 December 2016
Berichten: 3
Standaard

Citaat:
Oorspronkelijk geplaatst door Edmoor Bekijk bericht
Maak er dit van:
Code:
=ALS.FOUT(ALS(B12="jan";VERT.ZOEKEN(A12;F:J;2;ONWAAR);ALS(B12="feb";VERT.ZOEKEN(A12;F:J;3;ONWAAR);ALS(B12="mrt";VERT.ZOEKEN(A12;F:J;4;ONWAAR);ALS(B12="apr";VERT.ZOEKEN(A12;F:J;5;ONWAAR)))));0)
Top Edmoor! Werkt als een speer. Er verschijnen nu netjes nullen zodat het geheel weer bij elkaar optelt.
sr-1340 is offline   Met citaat antwoorden
Antwoord

Discussietools
Weergave

Regels voor berichten
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is Aan
Smileys zijn Aan
[IMG]-code is Aan
HTML-code is Uit

Forumnavigatie


Alle tijden zijn GMT +1. Het is nu 21:56.


Powered by vBulletin Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.