Belangrijk: ComputerIdee Forum Huisregels | Wachtwoord vergeten?

Ga terug   Computer Idee Forum > Software > Software Overige

Notices

Antwoord
 
Discussietools Weergave
Oud 20 November 2018, 00:10   #1
BlackTiger
 
BlackTiger's schermafbeelding
 
Geregistreerd: 4 May 2005
Locatie: State Penitentiary
Berichten: 11.251
Standaard Excel formule afronden

Ik wil Excel automatisch b.t.w. laten berekenen uit een bedrag incl. b.t.w. en daarvoor gebruik ik deze formule:
Code:
=ALS(C2>0;(C2/121)*21;"")
Oftwel als C2 groteri is dan 0 dan berekening uitvoeren, anders veld leeg laten.

Werkt prima, alleen door deze berekening gaat excel opeens behoorlijk afronden waardoor je op een gegeven moment een ongewenst verschil krijgt.

Dus moet ik deze formule afronden.
Nu heb ik dat als volgt geprobeerd:
Code:
=AFRONDEN(ALS(C2>0;(C2/121)*21;"");2)
Dat lijkt te werken, maar bij de lege velden krijg ik dan #### te zien en dat was juist niet de bedoeling.

Wat is de juiste formule om het door mij gewenste resultaat te krijgen of is dat niet mogelijk?
__________________
Greetings, Black Tiger

-----------------------------
Domme vragen bestaan niet. Het is dom om een vraag te hebben en deze niet te stellen.
BlackTiger is offline   Met citaat antwoorden
Oud 21 November 2018, 01:57   #2
BlackTiger
 
BlackTiger's schermafbeelding
 
Geregistreerd: 4 May 2005
Locatie: State Penitentiary
Berichten: 11.251
Standaard

Geen excel specialisten in huis?
__________________
Greetings, Black Tiger

-----------------------------
Domme vragen bestaan niet. Het is dom om een vraag te hebben en deze niet te stellen.
BlackTiger is offline   Met citaat antwoorden
Oud 22 November 2018, 20:55   #3
Jadatis
 
Geregistreerd: 17 November 2006
Berichten: 61
Standaard

Ik denk dat bij 2e formule alleen afgerond wordt als groter dan nul.
=ALS(C2>0;afronden((C2/121)*21;2);"")
Gaat denk ik wel het gewenste effect geven.
In jouw formule 2 gebeurt nu de afronding door cellen ingesteld staan op 2 decimalen. en dan denk je dat er afgerond wordt.

Laatst gewijzigd door Jadatis : 22 November 2018 om 21:06
Jadatis is offline   Met citaat antwoorden
Oud 22 November 2018, 22:41   #4
BlackTiger
 
BlackTiger's schermafbeelding
 
Geregistreerd: 4 May 2005
Locatie: State Penitentiary
Berichten: 11.251
Standaard

Dat klopt inderdaad Jadatis wat je zegt. Er staat ingesteld op 2 decimalen maar ik heb ook al door zoeken geleerd dat dan niet afgerond wordt.

Ik had de door jou opgegeven formule ook al geprobeerd maar dat deed het ook niet leek het.
Heb hem nu nogmaals geprobeerd en potverdikke ik had hem toch goed. Maar zag door de bomen het bos niet meer.
Er was namelijk 1 getal waar geen btw op berekend moest worden. En tijdens mijn eigen test vergat ik dat weg te halen.
Nu lette ik beter op (of was beter wakker) is dat getal verwijderd en nu klopt het wel precies.

Hartstikke bedankt!
__________________
Greetings, Black Tiger

-----------------------------
Domme vragen bestaan niet. Het is dom om een vraag te hebben en deze niet te stellen.
BlackTiger is offline   Met citaat antwoorden
Oud 22 November 2018, 23:21   #5
Jadatis
 
Geregistreerd: 17 November 2006
Berichten: 61
Standaard

Je kunt het ook nog verfraaien door BTW % in aparte cel te zetten en dan ( c1/ (100 + x5) ) * x5 oid . Dan kun je later inspelen op BTW veranderingen.
Moet dan oude btw % bewaard blijven, dan wordt het ingewikkelder, maar niet onmogelijk, iets met na bepaalde datum , en dan moet oude % met datum genoteerd worden.
Dat gaat mijn excell kennis te boven, maar anderen geven dan wel weer de pasklare oplossing daarvoor.
Jadatis is offline   Met citaat antwoorden
Oud 22 November 2018, 23:40   #6
BlackTiger
 
BlackTiger's schermafbeelding
 
Geregistreerd: 4 May 2005
Locatie: State Penitentiary
Berichten: 11.251
Standaard

Ja dat klopt, zo had ik het nu als tijdelijke oplossing gedaan ongeveer. In een verborgen cel de btw berekening laten doen zonder "als" statement met de afronding bijv. in J2, dat lukte wel.
En in de te gebruiken cel gewoon =ALS(C2>0);J2;"" gezet.

Maar dit is gemakkelijker. Zo vaak wijzigt de btw toch niet en anders is het 1 getal in die formule wijzigen en de boel weer naar onder trekken. En dit excelformulier is eigenlijk maar een controlesysteem wat ik ook uitprint voor de belastingadviseur die dan ook m'n btw aangifte doet.
Ik heb ook nog een boekhoudprogramma'tje. Feitelijk type ik daar in wat ik op de bank zie gebeuren.
Hetzelfde doe ik nog een keer in Excel.
En dan uiteindelijk als alles klaar is moeten de bedragen allemaal hetzelfde zijn. Je zou bijna zeggen dat je al geen fouten kunt maken met alleen al dat boekhoudprogramma. Maar het gebeurde toch vaak genoeg dat ik per ongeluk een dubbeltje teveel of te weinig had getypt of inkomsten in de uitgavenkolom had gezet en dan zie je snel dat er iets fout is.
Als je dan zo'n excel sheet ernaast kunt leggen is het een stuk sneller de fout terug vinden dan dat je alle banktransacties stuk voor stuk weer moet gaan checken.
__________________
Greetings, Black Tiger

-----------------------------
Domme vragen bestaan niet. Het is dom om een vraag te hebben en deze niet te stellen.
BlackTiger is offline   Met citaat antwoorden
Antwoord

Discussietools
Weergave

Regels voor berichten
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is Aan
Smileys zijn Aan
[IMG]-code is Aan
HTML-code is Uit

Forumnavigatie


Alle tijden zijn GMT +1. Het is nu 06:25.


Powered by vBulletin Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.