Ga terug   Computer Idee Forum > Internet > E-mail

Antwoord
 
Discussietools Weergave
Oud 21 November 2017, 20:12   #1
anoniem13758
Guest
 
Berichten: n/a
Standaard Mailserver onbereikbaar via wifi

Op mijn Synology nas heb ik een mailserver draaien. Op de telefoon kan ik berichten ontvangen en verzenden via mijn eigen domeinnaam wat ermee gekoppeld is. Alleen wanneer ik thuis ben en de wifi aanzet dan komt er een melding op de telefoon dat deze niet kan inloggen op de server. Wanneer ik de berichten ophaal via 4G is er niks aan de hand.

Op de PC thuis is er ook het probleem dat deze via het domeinnaam geen verbinding kan maken. Om binnen het eigen netwerk alles te laten werken is het nodig om in plaats van het domeinnaam het interne IP adres te gebruiken.

Wat is de oorzaak van dit euvel en hoe kan ik dit oplossen?
  Met citaat antwoorden
Oud 21 November 2017, 22:08   #2
anoniem14945
Guest
 
Berichten: n/a
Standaard

Dit is op zich normaal, dat je je externe ip niet vanaf je eigen netwerk kunt benaderen. Sommige routers ondersteunen zgn NAT loopback waardoor dat wel kan. Die van jou kennelijk niet, of het staat uit. In geavanceerde routers kun je je eigen lokale DNS configuratie doorvoeren, waarmee je het ook zou kunnen oplossen. Anders in het hosts file van de lokale machine, maar dat is alleen zinvol voor vaste computers.
  Met citaat antwoorden
Oud 22 November 2017, 15:37   #3
anoniem14733
Guest
 
Berichten: n/a
Standaard

Het verhaal van Foobar is correct. Zo ondersteunen sommige KPN modems geen nat-loopback, de modems van Ziggo wel, behalve de laatste nieuwe, de Connectbox, die ondersteund dat weer niet.

Maar ik antwoord eigenlijk vanwege het volgende.
Denk er ook aan dat dynamische ip adressen (dat hebben de meeste providers, dus ook KPN en Ziggo ondanks dat ze vaak hetzelfde blijven) geregistreerd staan bij Spamhaus. Dan heb ik het over hun hele range en dat doen ze zelf.
Reden is om spam tegen te gaan, wat vroeger veelal gebeurde vanuit thuis servertjes.

Je loopt dus bij het verzenden van e-mail het risico dat deze bij diverse providers en mailservers geblokkeerd c.q. teruggestuurd zal worden, ook al heb je correct SPF en DKIM gegevens ingesteld om maar eens iets te noemen.
Dat is alleen te omzeilen als je de smtp server van je provider als relay gebruikt in je mailserver.
  Met citaat antwoorden
Oud 22 November 2017, 19:28   #4
anoniem13758
Guest
 
Berichten: n/a
Standaard

Citaat:
Sommige routers ondersteunen zgn NAT loopback waardoor dat wel kan.
Deze kreet ken ik nog van mijn pogingen om een internet radiostation op te zetten. Daar had ik hetzelfde probleem. Dat ik daar niet eerder aan dacht.

@Blacktiger: Om bij ziggo mail te kunnen versturen is het noodzakelijk om een relay naar hun op te zetten. Anders werkt het gewoon niet. De reden is zoals je al aangaf. Vanwege de spam die vroeger werd verstuurd.
Hoe je een relayserver moet instellen kan je via google vinden.

Nu ik dit allemaal weet laat ik het zo. Het is niet echt een probleem dat het niet werkt via het domeinnaam. Moet nog wel de beveiliging even nakijken. Volgens mij wordt er op dit moment geen beveiligde verbinding toegepast. Gelukkig nog geen belangrijke dingen op het account staan.

Laatst gewijzigd door jeroenathome : 22 November 2017 om 19:31 Reden: Nog wat extra's toegevoegd.
  Met citaat antwoorden
Antwoord

Discussietools
Weergave

Regels voor berichten
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is Aan
Smileys zijn Aan
[IMG]-code is Aan
HTML-code is Uit

Forumnavigatie


Alle tijden zijn GMT +1. Het is nu 12:00.


Powered by vBulletin Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.