Discussie: Multiboot XP-W7-W10
Los bericht bekijken
Oud 26 October 2015, 12:40   #1
anoniem14942
Guest
 
Berichten: n/a
Standaard Multiboot XP-W7-W10

Hoi,

Ik heb al sinds 2010 een multiboot systeem: W7 Pro en XP Pro.
Ook na het stoppen van de support voor XP ben ik hiermee door blijven werken.
Omdat ik ook W10 wil gaan gebruiken, heb ik geprobeerd om XP binnen de disk waar XP is ge´nstalleerd te verplaatsen van partitie 1 naar partitie 3, op dezelfde disk dus.

Dit is helaas niet gelukt, met als resultaat, dat ik helemaal geen XP meer had.
Omdat ik dat systeem gebruik voor specifieke dingen, heb ik XP opnieuw ge´nstalleerd, meteen maar op partitie 3 (van disk 1). Heb verder alleen die dingen ge´nstalleerd die ik onder XP wil draaien. Een vrij sober en kaal systeem dus.
Op disk 0 partitie 1 heb ik W7 Pro draaien.
Om W10 als vrij schoon systeem op te kunnen zetten, heb ik op disk 1 partitie 1 (waar dus oorspronkelijk mijn XP stond) W7 opnieuw ge´nstalleerd. Had dit niet verwacht maar het werkte perfect.
Had dus een multiboot systeem met XP, W7 Pro en W7 Pro nieuw (voor upgrade naar W10) en kon alle drie de systemen zonder problemen booten.
Heb zo 2 a 3 weken probleemloos gewerkt.
Op 10 oktober op mijn W7 nieuw de upgrade naar W10 uitgevoerd, tot nu toe op zich redelijk vlekkeloos.
Ik kon nu dus booten: XP, W7 of W10. Dit heeft 3, 4 dagen geduurd, dagen waarin ik dagelijks ook XP opgestart heb.

Opeens kreeg ik, toen ik XP wilde booten, de foutmelding: ntoskrnl.exe missing or corrupt.
De volgende acties geprobeerd om het probleem op te lossen:
-Boot van XP installatie CD [in drive Q:] -Kies R
-kies 3 [XP op N:]
-Q:
-cd \i386
-expand ntoskrnl.ex_ n:\windows\system32
-expand ntoskrnl.ex_ n:\ ---> extra copy
-exit
-boot; probleem niet opgelost
-boot nogmaals van install-CD
-kies R - kies 3
-chkdsk n: /r
--chkdsk heeft een of meer fouten gevonden
-chkdsk n: /p
--meldt geen fouten
-chkdsk n: /r
--chkdsk geen fouten meer

-Boot W7
-via commandprompt expand q:\i386\ntoskrnl.ex_ n:\windows\system32\ntoskrnl.exe
-Boot XP geeft nog steeds hetzelfde probleem
-Boot W7
-via commandprompt: echo j | chkdsk n: /f /r /b > c: n.txt
--Het bestandssysteem is gecontroleerd. Er zijn geen problemen vastgesteld.
-Easybcd - Re-create/repair boot files
--Lost ook het probleem niet op
-copy de ntoskrnl van W7 naar XP --> missing or corrupt.
-copy de ntoskrnl van W10 naar XP --> missing or corrupt.


Ik denk zelf, dat het in principe niets met ntoskrnl.exe te maken heeft, het bestand staat op de juiste plaats en bevat na de expand toch zeker geen fouten.
Omdat ik al ruim 5 jaar probleemloos met de XP/W7 combinatie heb gewerkt, denk ik, dat W10 na een paar dagen (misschien door een automatische update) ergens iets vernaggelt heeft, maar dat kan ik niet echt met feiten onderbouwen.
De bootcfg en fixmbr en andere commando's heb ik deze keer niet gebruikt, omdat die naar mijn idee niet eventuele fouten uit ntoskrnl halen.
Mocht iemand dit probleem kennen en ook nog een oplossing weten, dan hoor ik dat graag.

NB Heb dit topic ook al op een ander forum geplaatst, maar heb daar niet veel response gehad, dus probeer ik het hier nog maar eens.

Alvast bedankt,
Marcel
  Met citaat antwoorden